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Introduction 
NorthClark's Bill of Material and Parts Master Maintenance module is a Windows based desktop 
application used to view, create, and modify Bills of Material and Part Master records in your Manfact 
system.  Features include: 
 

 Use a flexible spreadsheet format to easily add and delete items, or change the structure of a 
multi-level Bill of Material. 

 Import Bill of Material structures and Part Master details from an Excel spreadsheet or a tab-
delineated text file providing integration with virtually any CAD application. 

 Update the Manfact Bill of Material (BOM), Engineering Bill of Material (ENGBOM), and 
Work Order Bill of Material (WOBOM) files. 

 Create and update Item Master (PARTS) records.  

 Summarize the Bill of Material and customize output with flexible reporting options. 

 Export Bill of Material and Part data to Microsoft Excel. 

 Save partially updated or incomplete Bills of Material in a local Microsoft Access database, 
where they may be retrieved and posted to Manfact at a later time. 

 
Bill of Material Maintenance  
This window is used to view and/or update Bill of Material records in your Manfact system.   
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The Main screen is composed of three tabs: 

• General Display shows descriptive information about the selected Bill of Material. 
• Bill of Material Display is a spreadsheet environment used to create or edit a Bill of Material. 
• Item Detail Display contains information for a selected line item on the Bill of Material 

 

Open an Existing Bill of Material 

To retrieve an existing Bill of Material, select the Open command from the File Menu, or click the open 
button on the Toolbar:  

 

 
 

Select the desired Bill of Material Type:  Production, Engineering, or Work Order.  Enter the 
appropriate Engineering Change Order (ECO) or Work Order (WO) number if required.  Use the search 
buttons to look-up the Work Order Number and Assembly Number if desired.   

If your company uses Manfact’s multi-plant feature, and you want to create or update a plant-specific 
Bill of Material, select the Plant Code from the drop-down list.  If all plants share the same bill of 
material, this field should be left blank. 

You may view/update the Bill of Material using either a single-level or multi-level format.  Click the 
Explode Bill of Material Beyond First Level option if a multi-level view is desired, then use the drop-
down list to select the maximum number of levels to explode. 
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General Display 

The General tab displays information about the bill of material you are currently updating.  Data may 
not be changed using this view.   

 

 

General Display Field Descriptions: 

Field Name Description 

Assembly Number The top-level part number. 

Description The name or a brief description of the item. 

Configuration Plant If Manfact’s multi-plant feature is enabled, you may optionally configure a 
unique bill for each plant.  If this field is blank, then the BOM is generic for all 
plants. 

Owner Plant The plant that has ownership or primary control of the part. 

BOM File The name of the BOM file currently in use. 

WO or ECO Number The Work Order (WO) or Engineering Change Order (ECO) Bill of Material 
number. 

Revision Level Revision Level of the Assembly. 
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Bill of Material Display 
The Bill of Material Display is used to update or create Bill of Material records.  This view allows you 
to see and update all line items in the structure at the same time.  During data entry, the spreadsheet may 
be scrolled to the right to view additional columns. 
 

 

Bill of Material Display Field Descriptions 

Column Description 

[+] or [-]  The Bill of Material is a hierarchical structure displayed in outline form. Click 
[+] to expand an item and component parts, or [-] to collapse and hide 
component parts. 

Level [>] The roll up level of the item.  0 = Top assembly, 1 = 1st level sub-assembly, and 
so on.   

During entry or update of a BOM, use the Move Left (Outdent) or Move Right 
(Indent) option from the Edit Menu or the Outdent or Indent options found on 
the Right Click menu. 

Type Use the drop-down list to select the Type of line item. 

• Part:  An individual part or assembly. 
• Note:  Leave the part number blank and enter notes only. 
• Called Item:  The part entered at this line item must be an assembly with an 

XPL code of X or XP.  The assembly specified by this line item will be 
inserted at this line item, and considered part of this assembly. 

4 



NorthClark Computing, Inc.  

Column Description 

Part Number The Part Number for assemblies and parts. 

Description A brief description of the item.  For existing parts, the Description will default 
from the Part Master record and may not be updated except through Parts 
Master Entry.   

New The system will place a checkmark in this box any time a part is added that is 
not currently in your Manfact database.  This is a reminder that you will need to 
use the Part Master Update screen to complete the part record before the Bill of 
Material can be filed to the BOM, WOBOM, or ENGBOM files.  It may, 
however, be filed to the local database. 

Rev  Revision Level of the part.  For existing parts, the Rev Level will default from 
the Part Master record.  For existing parts, updating the Rev Level must be 
done through Parts Master Update.   

Hold Code For existing parts, the Hold Code will default from the Parts Master record.  
Changes to this field must be done through Parts Master Update.  The 
following codes are available: 

• D = Discontinued, no orders recommended. 
• U = Use up remaining stock. 
• O = Obsolete, do not issue to work order. 

U/M The Unit of Measure by which each Part is inventoried.  For existing parts, the 
U/M will default from the Parts Master record.  Changes to this field must be 
done through Parts Master Update. 

Unit Qty The quantity of this item required to produce the number of units defined in the 
Qty Per Factor field.  If the Qty Per Factor is 1, enter the quantity of this part 
required to build one assembly.  If the Qty Per Factor is 1000, enter the quantity 
required to build 1000 assemblies.  You may enter a numeric value, or select 
one of the following from the drop-down list: 

• AR = As Required 
• DWG = Drawing 
• REF = Reference 

Qty Per Factor The Unit Quantity will be divided by the factor entered in this field. 
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Column Description 

Ext Qty The Quantity of each item required for the top-level assembly: 

Ext Qty = Next Level Qty * Unit Qty / Qty Per Factor 

Where Next Level Qty is the extended quantity of the next higher (parent) 
assembly. 

Yield % The Yield Factor is used to plan for component shrinkage.  This value is 
expressed as the percentage of good units.  So, a factor of 95 means that 95% of 
the parts issued to a Work Order will be usable, and an estimated 5% will be 
scrapped. 

Yield Ext. Qty The total extended quantity required, taking the Yield Factor into account: 

     Yield Ext Qty = Ext Qty / Yield% / 100 

Issue Point Issue Points may be used to link required materials to a specific step on the 
Work Order routing.  This allows lead times to be adjusted so parts arrive just in 
time.  Please refer to the Manfact documentation for more information on 
setting up and using Issue Points.  

Effective Date The date the part becomes effective for use on this BOM. 

End Date The last date this part may be used on this BOM.  Leave this field blank if the 
part will be effective indefinitely. 

Use-up Stop This is a system maintained field posted by the Manfact Engineering Change 
system when a part has been flagged for Use Until Exhaust effectivity.  The 
system will stop searching for the use-up part as of this date. 

Balloon User defined drawing reference. 

Reference Designator User defined drawing reference. 

Notes Any notes to be included in the BOM. 

Alt. OK Check this box to approve the use of an alternate part. 

Eqv. OK Check this box to approve the use of an equivalent part. 

Alternate Parts List any alternates for this part. 

ECO History The system displays a list of Engineering Change Orders that have affected this 
line item. 

Used on Assembly The next level (parent) assembly on which this Part is used. 
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Item Detail Display 
The Item Detail Display is used to view or edit details for specific line items on the Bill of Material.  
This may be used as an alternative to the multi-line view presented in the Bill of Material Display. Any 
changes made on this screen will automatically update the Bill of Material Display.  

 

Select Insert Row from the Edit Menu or click the Insert Row icon on the top tool bar to insert new 
items using this view.  The item will be inserted immediately above the item where the Insert a Row 
feature was used. 

Use the Record Navigator (located in the lower left part of the screen) to scroll to the desired BOM line 
item: 

 
The leftmost button will move to the first line item, and the rightmost button will move to the last line 
item on the Bill of Material.  Use the two inside buttons to move to the previous or next line item.  If 
you hold down your left mouse-button, the previous/next commands will scroll continuously until the 
mouse-button is released. 
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Creating a New Bill of Material 
Selecting New from the File Menu will clear the screen allowing you to enter or import a new Bill of 
Material.  There are several ways to populate the new Bill of Material with data: 
 

• Enter information manually by selecting a cell and typing the appropriate data.  Certain cells use 
drop-down lists to allow you to select the information from a list.  The system will automatically 
load applicable Manfact Data when you enter a Part Number. 

• Rows, Cells, or Columns may be Copied and Pasted into your new BOM. 

• Import a Bill of Material from an existing spreadsheet. 

 

Saving a Bill of Material 
To save changes to the record you are creating, simply click the Save icon on the top toolbar, or select 
Save from the File Menu.  The screen illustrated below is displayed when you save a bill of material for 
the first time, or when you select Save As from the File Menu. 
 

 

When saving locally, you may choose any name you like for the file.  The .mdb file extension is 
customary for Microsoft Access databases.   

When Applicable, select the Configuration Plant and/or Owner Plant from the drop-down list.  Click the 
OK button to complete the save. 
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Importing a Bill of Material 
Any Bill of Material currently saved in spreadsheet format may be imported into the Bill of Material 
Maintenance Module.  Select Import a Bill of Material from the Activities Menu. 

 

 

 Select the Browse button to navigate to the desired spreadsheet file. 

 Use the drop-down list to select the appropriate mapping information.  Note: Your System 
Administrator must enter import and export mapping instructions for various spreadsheet 
formats using the Ncc_BomSetup application. 

 The remaining selections are set automatically with your map selection, but may be temporarily 
changed with this dialog.  If you receive an error message after clicking the OK button, the 
spread you are attempting to import may be in a slightly modified format, or incompatible with 
the selected map.   

 You may use this command to append to or combine existing BOMs.  If you currently have an 
open Bill of Material, a dialog appears asking if you wish to append to the existing spreadsheet. 

Note:  The Excel spreadsheet you are trying to import must be closed, otherwise you will receive a 
message indicating that 0 Parts have been loaded. 
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Translating Manufacturer Names During BOM Import 
If your company receives Bill of Material data from customers or other outside sources, it may be 
necessary to translate manufacturer names supplied on the spreadsheet to match the Manufacturer Codes 
defined in your Manfact system.  To accomplish this, choose the Update Manufacturer Name Cross 
Reference option from the Tools menu to create the cross-reference file, and when the Bill of Material is 
imported check the option:  Attempt to Translate Manufacturer Names. 
 

 

On the cross-reference table illustrated above, each row will translate a Manufacturer’s Name as shown 
on a spreadsheet, to a valid Manufacturer Code defined in the Manfact system.  Enter as many rows as 
needed to translate all of the names included in the spreadsheets your customer provides. 

Note that each translate instruction is associated to a specific Import Map, allowing you to define 
different mapping parameters for each customer who supplies Bill of Material data. 

The Search Criteria at the top of the screen are used to locate existing Manufacturer Cross-Reference 
entries.  Use the Map Name, Manufacturer Code, and Manufacturer Name prompts to narrow your 
search as desired, or leave all fields blank to retrieve all existing records. 

To permanently remove an entry, click the Delete checkbox on the offending row, then click the Save 
button. 
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Main Menu Options 

Following is a brief description of the options available from the Main Menu of the Bill of Material 
application. 

Menu Option Description 

Log In/Log Out LOG IN OR LOG OUT OF YOUR CURRENT SESSION 

New Clear all current data on all displays in preparation to enter a new Bill of 
Material. 

Open Open a specific BOM to view or update. 

Save Save the BOM to a specified database. 

Save As Save your changes to a database with a new file name. 

Revert to Last 
Save 

Restores your Bill of Material or PARTS List to its condition as of the 
last time you saved it to disk. 

Print Print the current active spreadsheet.  See Printing a Spreadsheet in the 
General information section for more information. 

Export Export data from the active spreadsheet.  See Exporting a Bill of 
Material Spreadsheet to Excel in the General information section for 
more information. 

File 

 

Exit Close the application 

Move Right  Allows the user to provide structure to the Bill of Material.  By moving 
Right you are indicating that this item is a sub-assembly to the assembly 
immediately preceding it. 

Move Left  Allows the user to provide structure to the Bill of Material.  By moving 
Left you are indicating that this item is a higher level assembly than the 
assembly immediately preceding it. 

Expand All Expand and show all levels of the Bill of Material. 

Collapse All Collapse all of the lower level items and show only the top-level 
assembly. 

Copy Copy data to the Windows clipboard.   

Edit 

 

Cut Cut data from the field and copy it to the Windows clipboard.   
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Paste Paste data from the Windows clipboard.   

Fill Update all of the selected cells from the Windows clipboard.   

Zoom Expand the contents of a field to view, print and/or edit.   

Insert Row Insert a row.  The row will insert immediately above the row where you 
have specified the command. 

Delete Row(s) Remove the selected row(s) from the Bill of Material. 

Unhide All 
Columns 

Expose all columns previously hidden.  (Columns are hidden via the 
Display Options.)  This allows you to view the hidden columns without 
changing the defined Display Options. 
 

Auto Fit 
Columns 

Automatically adjust the width of each column to accommodate your 
data.  

Hide/Show 
Cancelled Rows 

Hide or Show rows where the end date is less than or equal to today’s 
date. 

View 

Display Options Set user preferences affecting the appearance of the screen. 

Import a Bill of 
Material 

Import a Bill of Material currently saved in a spreadsheet format.  Activities 

Parts Master 
Update 

Load Parts Master data for the selected part. 

Part Number 
Search 

Locate a Manfact Part number using a variety of search criteria.  

Find a Bill of 
Material Item 

Find a specific item in the current Bill of Material. 

Display 
Drawing 

Display a drawing for a specific part number. 

Tools 

 

Update 
Manufacturer 
Name Cross 
Reference 

Search for a Manufacturer Name and/or Code. 
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Right Click Menu 

The following options are available from the Right-Click Menu of the Bill of Material application. 

Item Description 

Copy Copy data to the Windows clipboard. 

Cut Cut data from the field and copy it to the Windows clipboard. 

Paste Paste data from the Windows clipboard.   

Fill Update all of the selected cells from the Windows clipboard. 

Zoom Expand the contents of a field to view, print and/or edit.   

Insert Row Insert a row immediately above the row where you have specified the command. 

Delete Row(s) Remove the selected row(s) from the Bill of Material. 

Indent Row Allows the user to provide structure to the Bill of Material.  By moving Left you 
are indicating that this item is a higher level assembly than the assembly 
immediately preceding it 

Outdent Row Allows the user to provide structure to the Bill of Material.  By moving Right you 
are indicating that this item is a sub-assembly to the assembly immediately 
preceding it. 

Parts Master 
Update 

Load Parts Master data for the selected part. 

Part Notes Entry Enter public or private notes associated with the current part number. 
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Parts Master Update 
The Parts Master Update screen is used to enter information stored in either the Manfact PARTS or 
ENGPARTS file.  Use the General tab to view or update a list of Part Numbers in spreadsheet form.  
The remaining tabs present information for a single Part Number, organized by the major disciplines 
responsible for maintaining Part data: Engineering, Planning, Inventory, Purchasing, and Marketing.   
 

 
 
There are two ways to access the Parts Master Update screen:  
 

1. Right Click on any line item on the Bill of Material Maintenance window and select Parts 
Master Update from the drop-down list, and the system will display the available data for the 
selected Part Number. 

 
2. Select Parts Master Update from the Bill of Material Maintenance Activities Menu.  If you are 

currently editing a Bill of Material, the system will automatically select the correct file for the 
BOM you are editing.  If you have loaded an Engineering Bill, the ENGPARTS file will be used, 
otherwise the PARTS file is assumed.  If you have not opened a Bill of Material record, you will 
be prompted for the file to update: 

 

 
 

To change the file to be updated, choose the Open option from the File Menu of the Parts 
Update screen. 
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Load a List of Part Numbers / Summarized BOM 
This screen may be accessed by selecting the Summarize BOM option from the Activities menu on the 
Bill of Material Maintenance screen, or from the Tools menu on the Parts Master Update window.   
 

 

Summarized Bill of Material 
This option will display one row on the General spreadsheet for each unique Part Number used on the 
Bill of Material, including the total quantity required for each item.  The Summarized Bill of Material 
Quantity is calculated for the BOM currently open on the Main screen, based on the following options: 
 

Quantity to Build The extended required quantity of each part is multiplied by the Build Quantity 
you specify. 

Effective Date The date used to determine which parts are currently effective defaults to today’s 
date. 

Exclude “As 
Required” Parts 

Check this box to exclude Bill of Material line items with a non-numeric quantity 
(AR or DWG). 

Exclude Phantom 
Parts 

Check this box to exclude Part Numbers with an XPL Code of “XP”, also known 
as “Blow Through” items. 

Make / Buy Include manufactured items, purchased parts, or all items. 

Effective Limit the selection to effective or non-effective items based on the Effective Date. 
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New Parts Only for the Current Bill of Material 
This option displays each unique part number shown on the Bill of Material Display that does not 
already exist in the Manfact system.  This may be particularly useful when you have imported a bill of 
material with several new parts that need to be created before the bill can be filed. 

Use the List From the Last Parts Query Selection 
Part Number Search query is a separate program available from NorthClark Computing, Inc.  Choosing 
this option will load the list of part numbers resulting from the last search you performed using Part 
Number Search query.   
 
The Part Number Search query may be activated as any Windows application, by clicking the icon on 
your desktop or selecting it from your Start menu.  It may also be launched directly from this application 
by clicking the Parts Query button at the lower right of this screen. 
 

General Display 
The following fields are included on spreadsheet displayed on the General tab: 

Field Description 

Part Number The assigned identifier for Assemblies and Parts. 

Copy From Part Enter the identifier of an existing Part Number to copy. 

Description The name or a brief description of the item. 

Sum BOM Qty This column is displayed when you choose the option to Summarize a Bill of 
Material, otherwise it is hidden from view. 

XPL Code Select the appropriate code from the drop-down list: 

 (Blank) = for a purchased part. 
 X     = Assembly (Explode) 
 XP   = Phantom Assembly (Blow Through) 

 L      = Line Stock 

Issue U/M Select the Unit of Measure by which each Part is issued from the drop-down 
list. 

Hold Code Select the appropriate character to indicate a part is on hold from the drop-down 
list: 

(Blank) = No Hold 
D         = Discontinued, no orders recommended. 
U         = Use up remaining stock. 
O         = Obsolete, do not issue to work order. 
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Field Description 

Rev Level Revision Level of the item. 

Rev Date Revision Date of the item. 

Owner Plant The Plant that has ownership or primary control of the part. 

Part Type User defined. 

Category User defined. 

Notes Any notes to be included with the Part may be entered into the pop-up window.  
Click the OK button to save the notes. 

Exp. 1 Level Check this box to Explode one level when creating a work order. 

Purchase Assembly Check this box if the assembly is to be configured as a Buy part for costing 
purposes. 

Delete Flag Check this box to flag this PARTS record for deletion. Note: A part will not be 
deleted if it is linked to any open transactions. 

Made From The part(s) used to make this item.  This is used to support assemblies that are 
made by a supplier on a purchase order.   

Equivalents Approved equivalent Parts. 

Make / Buy Select Make or Buy from the drop-down list. The MRP process will not explode 
requirements for components of Buy items. 

Planner Code Code used to indicate the group or individual responsible for planning this part. 

Plan Fence Enter the Planning Time Fence in days. 

Demand Fence Enter the Demand Time Fence in days. 

Routing Routing Identifier (BOO File). 

Fcst Type Specify type for Sales Forecasting from the drop-down list. 

S = Spare 
F = Finished Goods 
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Field Description 

Order Policy Select MPS/MRP Order Policy from the drop-down list. 

D = Discrete (actual need) 
F = Fixed (minimum quantity over need) 
L = Least Total Cost 
P = Part Period Balancing 
T = Time Phased (need + need for next ‘x’ days) 

Days Supply The number of days that the Order Qty must cover requirements. 

Order Qty The minimum Order Quantity of each item. 

Order Multiple Enter the Order Multiple Quantity. 

Yield % Standard yield or shrinkage factor. 

MPS Check this box if the item is used by MPS and to be included in all Master 
Scheduled Part processing. 

MRP Check this box if the item is used by MRP.  If un-checked, the MRP process 
will not explode requirements for this item. 

Detailed Pegging Check this box if you want the MRP system to maintain Detailed Pegging for 
this part. 

Auto Release Check this box to enable Automatic Order Release, allowing the Planner 
System to automatically launch live orders. 

Buy Guide If checked, this part will be reported on the buying guide. 

Plan Lead Time The number of days required for planning this part. 

Assy/Buy Lead Time The number of days required to assemble or purchase this part. 

Total Lead Time Total lead-time for this part.  Usually Plan Lead Time + Assy/Buy Lead Time. 

Cum Lead Time The Cumulative Lead Time is calculated by adding the longest Total Lead Time 
at each level of the structure. 

PPB Cost Group Select the Cost Group to be used to determine unit cost for Part Period 
Balancing from the drop-down list. 
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Field Description 

PPB 2nd Policy Select Secondary Part Period Balancing Policy from the drop-down list. 

D = Discrete (actual need) 
F = Fixed (minimum quantity over need) 
P = Part Period Balancing. 

PPB Days Plan The number of days after which to switch to PPB 2nd Policy. 

PPB Place $ Enter the dollar amount of Order Placement Cost. 

PPB Place % The percentage of overall unit cost for Order Placement. 

PPB Setup $ Enter the dollar cost per order to set up for production. 

PPB Setup % The percentage of overall unit cost for Setup. 

PPB Carry $ Enter the cost per unit per day held in inventory. 

PPB Carry % The percentage of overall unit cost for holding the item in inventory. 

QA Inspect Check if this part is to be inspected by the QA system. 

QA Report Check this box if a QA Report is required for this part. 

QA Spec Code Enter the default QA Specification Code. 

Inspection Level Select the Inspection Level from the drop-down list. 

Serial Control If checked, Serial Numbers will be required for this item on each move. 

QA Notes Enter QA Notes into the pop-up window.  Click the OK button to save the 
notes. 

Lot Control If checked, Lot Numbers will be required for this item on each move. 

Fraction Qty Check to allow fractional quantities of this part. 

Stock Phantom Check this box if the assembly is a stockable phantom. 

Auto WO Close If checked, Work Orders with this part number will automatically close at 
month end. 

Freeze ABC If checked, Stratification (PARTS05) will not change the ABC Code. 

Safety Stock  The minimum quantity of the item to be in stock to assure continuous supply. 
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Field Description 

Max. Inv Maximum Inventory Level.  Not used for MRP items. 

Shelf Life The number of days the item may remain in inventory before expiration. 

ABC Code Select the alphabetic category for cycle counting frequency of this item from the 
drop-down list. 

Cost Groups Enter the Cost Group(s) to be used for this item. 

Buyer Code Enter Code for the individual normally responsible for buying this item. 

Load Factor Factor for distributing estimated freight costs. 

Price Conv. Conversion Factor used when Unit Price is not equal to Buy Unit Of Measure. 

Pur. Tax Type Select the default Purchase Tax Type code for this part from the drop-down list. 

Fcst Part Check this box if the part is forecasted.  It will be included in the Vendor 
Forecast Report. 

Fcst PO/SPO Select Forecast Planned Order (to meet MPS requirements) or Start Planned 
Order (offset by lead times) from the drop-down list. 

Prod Class Select Product Classification Code from the drop-down list. 

Sub Class Select Product Sub-Classification Code from the drop-down list. 

Mrk. Tax Type Select Marketing Tax Type Code from the drop-down list. 

Price Per Enter Price Per Unit Factor.  

Units / Package The normally shipped number of Units Per Package. 

Unit Weight Weight per Part per Unit of Measure. 

Clip Qty. Used by the buying guide and sales forecasting to “clip” or control unusually 
high demand for a part. 

Non Inv. Cost Unit cost for this item on non-inventory shipments. 

NSN Number U.S. Defense Department National Stock Number. 

NSN Desc. U.S. Govt. assigned Description. 

Ref Part Number Enter any internal alternate part numbers. 
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Field Description 

Complimentary Parts Enter any Complimentary Parts. 

Comp. Parts List Enter List(s) of Complimentary Parts. 

Substitute Parts Enter any Substitute Parts. 

Sub. Parts List Enter List(s) of Substitute Parts. 

OK To Sell If checked, this item is OK to sell. 

Auto Create WO If checked a WO will automatically be created for this assembly and all lower 
assemblies in the WO.B procedure. 

 

Navigating the List of Part Numbers 
While the General display allows you to edit multiple part numbers, the departmental views display data 
for only one part number at a time.  To navigate from one part number record to another use the record 
navigator buttons at the top right of the departmental display screens. 

 
 

Engineering Display 

The Engineering Display is used to make engineering related changes to PARTS or ENGPARTS 
records.  Changes made here will automatically update the General Display.   To add a new part or 
assembly, click the New Button next to the Part Number field. 
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Planning Display 
This tab includes parameters that affect Master Production Scheduling and Material Requirements 
Planning. 

 
 

Inventory Display 
This tab includes fields of interest for Inventory Control personnel. 
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Purchasing Display 
The information on this tab is used primarily for Procurement and Supply Chain Management purposes. 
 

 
 
The following fields are included in this view.  Note, these datasets are not available on the General tab. 
 
Column Description 

Vendor Number Vendor Number that this item has been purchased from. 

Vendor Name Name of the Vendor this item has been purchased from. 

Vendor Description Vendor’s Description of the part. 

Order Multiple The number of units the vendor will package together. 

Buy U/M Select the Buy Unit of Measure from the drop-down list.   

Buy U/M Factor Enter the conversion factor that will convert the Buy Unit of Measure to the 
Stocking Unit of Measure. 

Vendor Cost Last Vendor Cost per Buy Unit of Measure. 

Price Per Enter the factor that the unit price * total quantity will be divided by. 

Unit Freight Enter estimated freight cost per vendor unit. 

Last Cost Source Last Date * Document Number * Transaction Type that updated cost. 

Mfg Name and Part # Enter Manufacturer Name and Part Number in the pop-up window.  Click the 
OK button to save the changes. 

Plant Code The Plant Code associated with the part.  If nothing is entered then the part is 
available to all Plants. 
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Column Description 

Composite Rating The Composite Rating is made up of the Supplier's Quality, Cost and Delivery 
(QCD) ratings, as modified by the Weighting Factors.  These factors may be 
defined in the VENDOR file (updated via VEN.PC or NCC_BWBSupplier), 
and default values are entered using TABLE.VP.  The three Weighting Factors 
are: 

QW = Quality Performance Weight  
CW = Price (Cost) Performance Weight  
DW = Service (Delivery) Performance Weight 

The total of these percentages must equal 100%.  Each performance rating is 
multiplied by its weight, then the three ratings are added together to get the 
Composite Rating: 

QR = Quality Rating  
CW = Cost Rating  
DR = Delivery Rating 
Composite Rating = (QR * QW) + (CR * CW) + (DR * DW) 

Mfg ID The Manufacturer’s Identifier. 

Mfg Part Number The Manufacturer’s Part Number. 

Mfg Name The Name of the Manufacturer. 

Notes Enter notes in the pop-up window.  Click the OK button to save notes. 

Primary Check the box if this is the primary manufacturer desired for the part. 
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Marketing Display 
This tab includes parameters associated with Marketing and Sales Order Processing. 
 

 
 
In addition to the fields in the General Display Fields Description Table, the following fields may also 
be updated on this view: 
 

Column Description 

Customer Number Enter the Customer’s Number who purchases this item. 

Customer Part # Enter the Customer’s Part Number. 

Pack Qty Enter the number of units of this part that will be shipped together when 
calculating delivery quantities for this customer. 

JIT Check if Customer wants delivery Just In Time. 

SUN – SAT Check the normal ship day for this item. 
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The Complimentary and Substitute Parts and Part Lists command buttons will activate Popup Spreads 
for each related list. 

 
 

Entering Part Numbers 
To update a single record, simply type the identifier in an empty cell in the Part Number column of the 
spreadsheet on the General tab.  The system will read and display the current information from Manfact 
for editing.  If the Part Number entered is not found, you will be prompted to create a new record.  As an 
alternative, you may enter a new or existing identifier in the Part Number box on the Engineering tab. 
 

Automatic Part Number Assignment 
To assign a part number to a new part or parts select Assign a Part Number from the Parts Master 
Tools Menu. 
 
Note:   Perform this step before entering part data for the items you wish to assign.  If any data already 

exists in the spreadsheet the system will append rows and begin assigning numbers at the end of 
the current list. 

 

 

Enter the amount of Part ID Numbers you wish to assign and click the OK button.  The system will add 
the desired number of rows and sequentially fill the Part ID Column, starting with the lowest currently 
unassigned number.  Enter your new part data and save. 
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Tools  
Locate a Work Order Number 

The Work Order Search feature is available during the Open and Save dialogs: 

 

 
 

• If you are unsure of the part number, you may use wildcarding to search for a listing of Work 
Orders for parts that contain a portion of the Part Number. 

• You may narrow your search by selecting the appropriate status.  Click on the icon to the right of 
the Status field. 

• You may also narrow your search to a specific warehouse by selecting one from the drop-down 
list. 

• You may select a work order by double-clicking on the desired row, or by positioning the 
highlight-bar and clicking the Open button on the bottom of the screen. 
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Part Number Search 
The Part Number Search query helps you locate a Manfact Part Number using a variety of search criteria 
and provides you with an Inquiry Only process for users who do not have Parts Master Update 
authorization.  
 
The main screen is composed of eight tabs. The Search and Results tabs are the two tabs that will be 
utilized in locating a part number.  The remaining tabs display information that is contained in the 
Manfact PARTS and Inventory files, organized by departments: Engineering, Planning, Material, 
Purchasing, Marketing and On Hand.  
 

 

Locating a Part Number  
Selecting Part Number Search from the Tools menu will display the search tab.  If you know the part 
number that you want to inquire on, enter the part number and click on the Enter key.  The engineering 
tab will be displayed.  If you don’t know the specific part number, but know some basic information 
about the item, several fields are available to use in narrowing your search.  
 
The fields you may use in your search include:  Part Number, Description, Vendor Description, 
Mfg#*Part#, Notes, Vendor #, Product Class, Sub-Class, Part Type, Category, Buyer, Planner, and 
Make/Buy Code.  You may use as many of the search fields as necessary to narrow your search to the 
fewest number of records.  If you don’t know the specific details of a particular field, you might use 
wildcarding to enter only a portion of the item’s part number, description, etc.   
 
To further assist you in locating the desired part number, you may Sort the search results by either the 
Manfact Part Number or the Engineering Description.  Select the Search button and the Results tab will 
be displayed. 
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Search Results 
One part number and its associated description are displayed on each row of the list.  You can change 
the way the information is sorted by returning to the Search window and using the Sort By option.  
 

 

Please refer to the Part Number Search Query User Guide for more information. 

Note:   The NCC Part Number Search Query is sold separately.  If this option is not currently available, 
please contact your System Administrator or NorthClark Computing, Inc. to obtain a copy of 
NCC_PARTSQ. 
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Find a Bill of Material Item 
The Find a Bill of Material Item procedure allows you to quickly locate items that have been included 
on your open Bill of Material.  Use the screen below to enter the criteria for the item you wish to find. 
 

 

 Select the Search Field from the drop-down list 

 Enter the Text you wish to match and select whether you wish to Match the Case (case sensitive) 
or Match the Whole Field Only (searching for an exact match). 

 Click the OK button to begin the search. 

 Once located you may proceed to perform the necessary review or update to the data. 
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Data Warehouse Management 
The NorthClark Data Warehouse Management module allows you to store drawings, specifications, and 
related documents in a centralized folder that can be easily access from various applications.  Select 
Display Drawing from the Tools Menu to enter the Part Number for the drawing you wish to view.   
 

 

Please refer to the Data Warehouse Management User Guide for more information. 
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Part Notes Entry (from Right Click Menu) 
From the Right Click Menu you may enter notes associated with the current part number.  Enter the 
Notes, either Public or Private and click OK to save the notes. 
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General Information 
Printing a Spreadsheet 
To print the current active spreadsheet, select the Print option from the File menu.   

 

Range 
You may choose to print All (the entire spreadsheet), Selected Cells (those that you have highlighted 
on the current screen), Current Page (only the rows that are currently visible on your screen), or 
Pages (any range of page numbers).  

Orientation 
You may print your report in portrait mode (normal) or landscape mode (sideways).  Printing in 
landscape mode will allow you to fit more columns of information on your report.  

Margins 
You can make your report more attractive by setting the top, bottom, left, and right margins.  Reduce 
the left and right margins to fit more columns on the report.  

Units 
Select inches or centimeters to designate the unit of measure for the entered margins. 
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Page Order  
If your report is too wide to fit on a single page, it may span multiple pages.  When this occurs, select 
your preference to have the report printed from top to bottom or left to right.  

Print 
You can customize the appearance of your report by printing (or not printing) column headers, row 
headers, grid lines, borders, shadow, and color.  

Headers and Footers  
Your report may have up to three lines for the heading, and one line for the footer.  The system 
initially displays a default heading, which you may modify if desired. 

Tip: Use /p to designate a page number.  

Columns to Print  
The columns that are available for printing are listed.  Select the columns you wish to include on your 
report.  

Importing Data    
To import a Bill of Material from Excel, see Importing a Bill of Material.  Data other than a Bill of 
Material may be imported from a Microsoft Excel spreadsheet, a tab-delimited text file, or a comma-
separated text file.  Open the desired spreadsheet which is to receive the imported data via the File 
Search button. 
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Import File Name  
Enter the path for the file that you wish to import.  You may browse the files by clicking on the 
button next to the text box. 

Header Rows

Enter the number of rows at the beginning of the file that are not to be imported. 

Import File Type
Select the type of file that you are importing. 

Data Mapping
Enter the Column Number or Letter where data resides on the Excel file.  Use the Reset button to 
restore the fields to their original state.  Use the Clear button to clear all fields.  Use the Auto 
Number button to automatically number the values sequentially. 

Import Data
Click the OK button to begin the import procedure. 
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Exporting a Bill of Material Spreadsheet 
From the spreadsheet you wish to export select Export from the File menu in the Bill of Material 
Maintenance module.   
 

 

Map Name 
Select the name of the import/export map you wish to use from the drop-down list. 

Excel Template 
As an option an Excel template may be selected to add headings, borders and other graphics to your 
report. 

Excel File Name to Create 

Enter the Excel Sheet Name to create. This will automatically default to Sheet1. 

Spreadsheet Format 
You Excel workbook may contain multiple sheets.  The first (Master) sheet is usually a single-level 
bill for the top assembly.  If you have a multi-level bill, a separate sheet will be generated for each 
sub-assembly contain herein.  Select the sheet(s) you wish to produce using the radio buttons on this 
screen. 

Maximum Level to Include on Master Sheet 
Enter the number of levels to explode for the Master sheet.  Enter ‘1’ for a single-level bill. 

Export Expired Rows
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Check the Export Expired Rows button to export expired rows.  Leave it blank to not export expired 
rows. 

Export Button 
After all required information has been entered, click the Export button to export your data to 
Microsoft Excel. 
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Exporting All Other Spreadsheets 
You may export the contents of displays, such as Parts Master Maintenance, directly to Excel, or you 
may choose to create a file in Excel format.  The format of the Excel file will match the layout of the 
spreadsheet on your screen. 
 

 

Save As File Name 
Enter the pathname of the file you wish to create. 

Save As Sheet Name 

Enter the Excel Sheet Name to create.  This field will automatically default to Sheet1. 

Export Directly to Excel 
This is the easiest way to export data.  If Excel is not already running on your computer, the system will 
attempt to start it.  The information from the display is then loaded directly into corresponding cells in 
the Excel spreadsheet. This option may be used with either Microsoft Excel 95 or Excel 97. 

Export to File in Excel Format 

This option allows you to create a file in Microsoft Excel 97 format (BIFF8). This option may be 
preferable when exporting large amounts of data.   

Create a Log File 
Select this option to create a log file.  The log file contains error messages and other information about 
how your Excel file was created. The name of the log file will be “CreateExcelFile.log”, and it will be 
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stored in the same folder as the spreadsheet. 

Data Mapping 
Data Mapping allows you to change the sequence in which the data will be stored.  Use the Reset button 
to restore the fields to their original state.  Use the Clear button to clear all fields.  Use the Auto 
Number button to automatically number the values sequentially. 

Export Button 
After all required information has been entered click the Export button to export your data to Microsoft 
Excel. 
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Editing Features 

Copy, Cut, Paste and Fill 
You may use the standard Windows Copy, Cut, and Paste features to copy or cut data to the Windows 
clipboard, or to paste data from the clipboard into a cell.  

To copy data, hold down the left mouse button and highlight one or more cells.  Choose one of the 
following methods to copy the highlighted cells to the clipboard:  

1.  From the Edit menu choose Copy. 

2.  Click the Right Mouse button, and choose Copy from the drop-down list.  

3.  Click the copy icon (two overlapping sheets of paper) on the toolbar.  

4.  Hold down the Ctrl key and type the letter C (Ctrl-C). 

The above methods can be used to Cut (Ctrl-X/Scissors icon) and Paste (Ctrl-V/Clipboard with paper 
icon).  

To copy and/or cut the contents of an entire row, click once on the row header (the number displayed on 
the left side of the first cell), then choose Copy and/or Cut.  Click on the row header that you want to 
copy the data to and choose Paste. 

To update several cells with the same value, highlight all of the cells you wish to update then select Fill 
from the Edit Menu or from the right click menu.  This command will update each cell with the current 
information from the clipboard. 

Zoom 
This feature allows you to view, print and/or edit the expanded contents of a field.  It is especially useful 
for multi-line information such as notes and long descriptions. 

• Zoom in on any selected item by selecting Zoom from the Edit Menu, clicking the magnifying 
glass on the toolbar, or selecting Zoom from the right click menu.   

• The Column Name will appear in the Title Bar with Edit (an editable field) or View (a view only 
field).  Make any entries or changes desired and click the OK button when finished, or the 
Cancel button to revert to the original data.  

• Locked fields may be viewed but not modified using the Zoom Feature.  If the field is locked, 
View will appear in the Title Bar, and there will only be a single command button labeled Done. 

• To print the selected item, click on the printer icon and the information will be sent to your local 
printer. 
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Customizing Your Display / Arranging Columns 
Select Display Options from the View Menu to customize the display.  

 

 Each tab contains a list of fields that corresponds to a screen used in this application.  Click the 
checkboxes to show (a checkmark in the box) or hide (a blank value in the box) each field 

 Use the Move Up and Move Down Buttons to re-arrange the order in which the fields appear on 
the specific screen Display.  Click Reset All to return to the system’s default settings. 

 To select the color for highlighting rows that have been modified, during data entry, but not 
saved, click the Select Color for Changed Rows button.   

 You may opt for the system to Remember Screen Size and Column Widths. Any changes you 
make to the screen's appearance will be saved and applied the next time you launch this 
application.  

 On the BOM Screen you may choose the option to Indent Part Number by Level. 

 Choose the number of columns (from left to right) you wish to freeze on the spreadsheet. A 
frozen column will remain in place as you scroll to the right.  

 Click the OK button to apply any changes you have made or the Cancel button to revert to the 
previous settings. 

Note:  These settings are stored in the Windows Registry for each user. 
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Wildcarding 
Wildcarding is a powerful feature that allows you to search using a portion of the field.  You tell the 
system you want to use a wildcard by typing three periods “…” or an asterisk “*” at the beginning or 
end of your search entry.  See the table below for examples of wildcard commands and their expected 
results. 
 

Item Sample Description 

Part Number  XTR…  or XTR* Returns part numbers that begin with “XTR”  

Description …VALVE… or 
*VALVE*  

Returns parts with the word “VALVE” anywhere in the 
description.  

Category …A or *A  Returns parts with a category ending with the letter “A”. 
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